1 2 3
RichardSIA
RichardSIA Reader
10/8/19 9:10 p.m.

Small but important progress. smiley

RichardSIA
RichardSIA Reader
10/14/19 12:56 a.m.

Pulled the transmission today so that I might free the stuck clutch.

By myself, as usual.

But there's little chance I be able to get it back in by myself.

Disc was a little bit rusted to the flywheel.

Also some damage to the TO bearing.

And the ring gear is shot, badly worn in one area.

Hope to order parts in the morning, if the holiday does not prevent me. 

Probably ordering from England as it seems the U.S. Rover parts dealers are just a bit too greedy.

Even after air shipment the UK is clearly cheaper.

Today the exchange rate was $1.00 - £.79

 I want to buy as many parts as possible before the rate gets bad again.

RichardSIA
RichardSIA Reader
10/15/19 12:16 p.m.

Well, another $450.00 in parts from England. 

Half of that is a new flywheel and ring gear.

The flywheel itself was fairly cheap at less than $100.00 compared to over $300.00 for JUST the ring gear in the U.S.!

Too bad I was not able to easily buy just the ring gear from the UK, but that would have required a separate shipment that would have killed the savings.

 

It gets "Interesting" when you try to support an exotic car!

At least now I will have printed shop and operators manuals.

RichardSIA
RichardSIA Reader
10/19/19 6:53 p.m.

If I had been home this morning the 101 parts I ordered from the UK Wednesday night would have been delivered today.

I get both faster delivery and better prices from the UK than from US sources.

RichardSIA
RichardSIA Reader
10/21/19 9:16 p.m.

With the new TO bearing in hand I may have found my root issue with the clutch.

Need to relocate my camera again to post a pic.

But it seems the plastic bearing holder of the old TO has been rubbing the hub of the friction disc.

The new (OE style) version cannot do that.

Seems to be an odd issue since at such low mileage I would expect all parts to be the originals from the factory.

Got a complete NOS flywheel from the UK cheaper than a ring gear from US sources.

Shiny new, and I hate even surface rust, so I painted the back side and outer edge.

RichardSIA
RichardSIA Reader
10/25/19 10:30 p.m.

Flywheel and clutch are back on the engine.

Working alone, so I will be making a set of guide pins to help get the transmission lined up.

Hope is to get it done on Saturday.

Once the clutch works I will get into the electrics.

It's not really Lucas that is the problem, it's sitting unused so the contacts get slightly corroded.

Sitting in the humid No. CA bay area only makes it worse.

RichardSIA
RichardSIA Reader
10/26/19 9:24 p.m.

Six more bolts.

Nearly back together.

Then bleed the clutch once more and it had better work.

Without the guide pins I never would have been able to do this all on my own.

RichardSIA
RichardSIA Reader
10/27/19 10:26 p.m.

Not happy.
Pulling air from somewhere so cannot get a good clutch bleed.
I will have to track it down on a warmer day.
Not many of those left in this year.

TurnerX19
TurnerX19 Dork
10/28/19 8:23 a.m.

In reply to RichardSIA :

Air can suck in from the slave or the master. I would replace both given the age of the truck.Or try o rebuild if the bores are honeable still. 

RichardSIA
RichardSIA Reader
10/28/19 11:15 a.m.

Both are already new.

Also all rubber lines.

I'm suspecting the fluid reservoir connection.

TurnerX19
TurnerX19 Dork
10/28/19 2:44 p.m.

In reply to RichardSIA :

Or you got a bad new part. As someone else on this board (curtis?) mentioned, a new part has never worked, and I have seen far too many bad new parts to trust anything.

RichardSIA
RichardSIA Reader
10/28/19 9:56 p.m.

Found a Permatex product to seal the unions, at $40.00 for a couple of ounces!

Still cannot get my Rover clutch to bleed.
Using a vacuum bleeder but continually pulling air from somewhere.
Most likely culprits seem to be the attachments to the remote reservoir before it reaches the MC.
But it could be as simple as the bleed screw letting air past when it's loosened.  
Several sections of line so many possibilities.
Seems the simple way to determine this would be some sort of temporary spray at the unions, but what?
Do not want to create a sticky mess, do not want to contaminate the brake system. 

If I cannot get this figured out I may have to modify a rather expensive reservoir top to function with a pressure bleeder.
That might reveal a fluid leak that I could then fix, but would be unsightly. 

Brett_Murphy
Brett_Murphy UltimaDork
10/28/19 10:34 p.m.

This is great. Keep it up!

TurnerX19
TurnerX19 Dork
10/28/19 10:50 p.m.

In reply to RichardSIA :

Post a picture of the reservoir top. It may be familiar to me. Also I have found almost every bleeder screw will leak a little at the threads when loosened. I now go to the trouble to make a pressure fitting for everything I do. I use a Motive brand (garden sprayer) and never put fluid in the tool itself, I only use it to pressurize the car's reservoir. Yes it is a little annoying to keep filling, but putting fluid in a pressure vessel that you use as seldom as I do is begging for moisture contamination. Only takes 5 psi and I have used it on everything from a Gemini F. Jr.  to  my DD Volvo. Little integrated Girling master cylinders are the worst for small capacity.

RichardSIA
RichardSIA Reader
10/29/19 1:41 a.m.

I don't have a pic handy but this link is what I'm using.

double-2-e1543327219854-1600x954.jpg

Over 2" in Dia., custom billet part from the UK.

If it were not metric thread* I would have already made another cap to use with my garden sprayer pressure bleeder.

May still have to do that, but making the cap and clamp to hold it in place will not be easy.

Getting my vacuum bleeder to work "Should" be simpler.

 

*No metric capability with my South Bend lathe.

TurnerX19
TurnerX19 Dork
10/29/19 7:17 a.m.

That sure looks like an aluminium replacement for the large Girling remote reservoir. Plastic Girling cap is sometimes available and cheap when it is. Might be the same thread too. Are you sure that is a metric pitch? The brits never discard a machine tool!

RichardSIA
RichardSIA Reader
10/29/19 1:32 p.m.

Yes, I tried my pitch gauge.

I think it's an infection from the EU (Eeeuuwww!) mandates, several replacement fasteners are suddenly metric headed instead of imperial.

I think I've figured out a work-around for the cap, just a couple hours of lathe work required.

Then some all-thread, a bar, and wing nuts.

Keith Tanner
Keith Tanner MegaDork
10/29/19 1:53 p.m.

Maybe it's a Whitworth thread ;)

RichardSIA
RichardSIA Reader
11/2/19 9:42 p.m.

And I now have a working clutch!
Still a bit low, but functional enough to finally get a drive to the gas station.

The solution was fairly simple.
I just had to remember a bit of experience from my youth.
It seems that sometimes the steel line will not fully conform to a new hose connection.
Back in the day soft copper washers were readily available to use as a gasket.
Now copper washers in the proper size are near impossible, but I did find some in aluminum.
So a washer at the union at the bottom of the reservoir and another at the hard-line to the slave.
Also replaced the too thin copper washer at the slave end of the hose with aluminum.
Now the vacuum bleeder was able to pull fluid.
Still needs to be bled a bit better but now I should be able to do that in the conventional manner. With the end of the hose submerged in brake fluid.

Now, about the lights.....

TurnerX19
TurnerX19 Dork
11/3/19 3:31 p.m.

Now, about the lights.....Remember the motto on Lucas' wall  "A good days work and home before dark"

RichardSIA
RichardSIA Reader
11/3/19 11:55 p.m.

Of all the dozens of British vehicles I have owned, this is the first to actually justify all those lame Lucas jokes!

I have headlamps now, and most of the rest.

Just REMOVE a wire!

Actually the proper fix is to bypass a special relay related to military use IR lighting.

And the REAL proper fix is to replace the inexpensive relay with a new one, since it also affects other circuits.

I'm buying extras!

So nearly a driver and hopefully my last required UK buy for a while.

RichardSIA
RichardSIA Reader
11/4/19 11:19 p.m.

Nuts!

Took a short drive after adjusting the brakes.

Leaving a local parking lot the engine suddenly quit, like I had turned it off.

Fiddled with it but no success.

Walked a couple of blocks to my shop for tools.

Have fuel, distributor turns, points work, full power to the coil, but no spark from the coil. sad

Since it's a shielded ignition there are a few more related parts than standard to be looked at.

Naturally this happened just before dark.

In the morning I will be able to look at more connections in the hope it's just a loose wire.

A replacement coil is £55.00 and shipping.

I no longer even look for U.S. parts sources as they are just too greedy at the current exchange rate.

 

RichardSIA
RichardSIA Reader
11/6/19 9:47 p.m.

I've been attempting to get the engine running again.

Zero spark from the coil. Being an FFR vehicle it is a 24V system with a voltage drop/filter for the coil.

When I measured my Filter Box output I got 24.8V which should be more like 10V.
Gave up and removed it and the coil.
Took the box somewhat apart and on visual inspection found a break in the fine wires of the resistance wiring.  sad
The rest of the unit appears to be very clean, but I cannot perform checks on it unless I repair the broken wire first.
Or find a replacement part. laugh
So, anyone have a specification for the wire?
And just to be silly, a source for new capacitors?

Have not tested the coil yet but I intend to.
At least it was installed properly for polarity, but the HT lead is a mess at both ends.
Distributor end has a finishing nail pushed into it, coil end has what might have been a paper clip?
Certainly not the spring loaded brass buttons and insulators I would have expected for shielded wiring.
What IS the current rating of a finishing nail?  enlightened
Might be the reason for failure?

So it looks like another couple of weeks before I get to drive it again.
But the new set-up should be much more reliable, necessary as I'm prone to wondering off alone to find where a trail ends.  devil
Not considered good form hereabout, but I no longer have anyone local to accompany me. sad

akylekoz
akylekoz SuperDork
11/7/19 7:25 a.m.

I would install a bike mount in the back somewhere, you know to carry a vintage cruiser.

RichardSIA
RichardSIA Reader
11/7/19 11:57 a.m.

Ya had to bring that up! 

No longer have my Rokon RT-340 either. crying

Or the BSA 441. frown

 

 

1 2 3
Our Preferred Partners
J0cdgISef5c69l7n5i5DU2zn82e8wvyOPcFpdIOALviFrUWKXGWwbEV5U6tEAkqT