1 2 3
EvanB
EvanB MegaDork
9/14/18 10:35 p.m.

Tuning is the easy part.

icdpride
icdpride New Reader
9/17/18 2:49 p.m.
EvanB said:

Tuning is the easy part.

Maybe if you know what you are doing, but can 100% assure you I do not lol

Matthew Kennedy
Matthew Kennedy Reader
9/19/18 1:12 a.m.

I'm happy to try and help from afar with the tune.  I'm also running a stock 530 head and IPD turbo cam, so it should at least be close (except up at the top, because your turbo is much much larger than mine).

icdpride
icdpride New Reader
9/20/18 9:53 p.m.
Matthew Kennedy said:

I'm happy to try and help from afar with the tune.  I'm also running a stock 530 head and IPD turbo cam, so it should at least be close (except up at the top, because your turbo is much much larger than mine).

Dude that would be killer!!! this is my current tune https://drive.google.com/open?id=1p7iX6l57HmM5MpuWz4XXwHTmtjCxQVa5

I will get back to tuning and data logging soon the whole return fuel line split in 2 places. 

But please let me know what would help to post or share I appreciate every bit of input 

icdpride
icdpride New Reader
9/24/18 8:57 a.m.

Great news! I got it started and running yesterday 

<iframe width="560" height="315" src="https://www.youtube.com/embed/R1LRLoqLFOE" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>

https://www.youtube.com/embed/R1LRLoqLFOE

Bad news is after running for around 15 mins it just shut off, then when I went to start it it sounds like the starter is bad so I could not get it restarted. I will get a video of that later but it sounds weird.

Is it possible for a starter to go bad and cause the car to shut off? Like draw enough current to starve all the other components and shut off the car even through it is not engaged?

The car still turns over fine but a hand ratchet so I am kinda stumped. I will replace the starter and go from there but just is really strange. I swear I am usually got at cars 

Matthew Kennedy
Matthew Kennedy Reader
9/24/18 8:21 p.m.

It sounds healthy from here!

How's voltage at the starter look? Is everything else getting power?  It looks like you've relocated the battery, so it is possible that there's a shoddy connection somewhere in that chain.  If the starter is behaving like it's low on voltage, it could be that the connection is crappy, and the starter is fine.  The things to check are voltage across the terminals at the battery, and the voltage between the big positive lug on the starter and the block.  Does the megasquirt have power when you turn the key on? What voltage does it show?

icdpride
icdpride New Reader
9/25/18 8:35 a.m.

Well it for sure seems like its the starter between the smoke and the grinding I think I am right need to pull it and confirm 

<iframe width="560" height="315" src="https://www.youtube.com/embed/LKhOC6_zv1Q" frameborder="0" allow="autoplay; encrypted-media" allowfullscreen></iframe>

At the end there is some smoke, I checked all the wires nothing is melted or hot so I am assuming is the starter 

Anyone know why a starter that has maybe 30-40 starts on it would go bad so fast?

icdpride
icdpride New Reader
9/25/18 8:38 a.m.

In reply to Matthew Kennedy :

Voltage looks good it is getting 12.7v, yup everything else is getting power. The batter was relocated using a BMW main wire and tested out ok. I am thinking its the starter because everything else seems fine Megasquirt is reading 12v. I am going to pull the starter tonight and test it outside the car 

icdpride
icdpride New Reader
9/27/18 9:30 a.m.

Test fitting the back flares I think they look pretty good might need to heat them and bend them a little tighter but I think it looks good this tucked 

icdpride
icdpride New Reader
10/8/18 10:30 a.m.

Made the final cuts rivenutted the fenders and final mounted them I really like the way these cheap flares tuned out. Just waiting on a starter so I can get back to tuning and hopefully driving soon 

 

1 2 3
Our Preferred Partners
Ua7XOhpAUIuBWPy7QqrNgBreAfxHMrhp1FhyJ8dNs0jzBBIAkLEE8IS1YfGTmLaS