7 8 9
russ_mill
russ_mill Reader
7/7/21 9:01 a.m.

So ordered some Bilstein 5100s plus OME shocks (880 front/906 rear- should about match current height plus an inch). Will come assembled with new top hats for the front, and a local shop will put them in as I'm not ready in any way for heavy lifting. 
Im tired of getting bounced around like crazy on every bump! Plus the rear is at different ride heights at the moment, with mismatched shocks. 230k, and she deserves a whole refresh!

 

russ_mill
russ_mill Reader
7/29/21 9:03 p.m.

Well the bilsteins/OMEs ride great! So great I'm just going to sell the TL. Too much going on in my life for numerous cars! 
Ill snap a pic tomorrow! 

pimpm3 (Forum Supporter)
pimpm3 (Forum Supporter) UltraDork
7/29/21 9:32 p.m.

You should be able to sell the stock springs.  Since the truck is a highlander edition its oem springs are taller then typical 4x4 4runner ones.

Glad you are enjoying the truck!  I put a set of 5100's on the titan i replaced the 4runner with.

AnthonyGS (Forum Supporter)
AnthonyGS (Forum Supporter) SuperDork
7/30/21 9:06 a.m.

I've considered these Bilsteins for my daily driver too.  I look forward to more updates on them and fluid film.  I may be getting a more expensive rust prone Subaru too so fluid film may also be in my future.

russ_mill
russ_mill Reader
7/30/21 6:51 p.m.

Yup, sold the springs! 
 

Anthony- the 5100s are many times better than the mismatched stockers that were on there. It's definitely more stable in the turns and soaks up bumps better, but will still unsettle the rear on a turn if I hit a large bump. 
still some squeaks and rattles, but then again it is a 22 year old SUV, and I'm used to cars. 
 

I guess what I'm saying is I'm happy, but I don't have much to compare it to either! 

solfly
solfly Dork
7/31/21 6:07 a.m.

Here I am looking at the last page wondering why you put OME springs on a Vette...

russ_mill
russ_mill Reader
7/31/21 6:54 a.m.

In reply to solfly :

To be more like the "B is for Build" guys lol. 

russ_mill
russ_mill Reader
8/10/21 2:56 p.m.

A little progress changing the fuel filter, and chasing down shakes and rattles. 
 

Old fuel filter didn't look too bad, but the bracket was hacked up with a broken bolt in the tightening mechanism. 

So I cut that off, painted, and now have stainless hardware in there. 

She runs a little smoother now. 

Next I chased down squeaks/rattles. I replaced as much missing plastic interior hardware as I could find, cleaned and greased all the door hinges, and took the cargo door plastic off to find a loose electric box. So I put plenty of  sound insulation behind that, taped it down, and buttoned it all up. 

Thats  one less major rattle, but I still hear some smaller stuff. Progress is progress though!

russ_mill
russ_mill Reader
10/12/21 2:26 p.m.

I haven't updated this in awhile, but it's not for a lack of work. In a bit of out-of-order fashion, here we go: 

-Marlin crawler heavy duty shift seats and sockets installed. This fixed my notchy first gear (for the most part). For $20 and 20 minutes, I highly suggest this mod. 
 

-New Toyota upper ball joints, and moog upper control arm bushings. I cleaned up the upper control arms real well, painted them, and used plenty of anti-seize. Here's what the upper bushings were looking like: 

The truck drives much better now, and I feel safer knowing all my ball joints are new (I did lower a few k ago). 
 

-I relocated my turn signals to the parking light housings with an led kit (which is not bright enough so I'll need to get brighter LEDs), and that gave me a space in the lower bumper so I filled it with LED fogs (OEM fogs were broken anyways). Actually most of the lights are LED now, except for the headlights because I don't have the correct housings. I did get new halogens for my headlights though.

I also trimmed the lower bumper up a bit.

looks a lot better now! 
 

-I relocated my very large wiper fluid reservoir into a smaller one that fits into the engine compartment. No pics as I'm not done/happy with it yet. 
 

-I removed the side cladding and spoiler because it made the wheels look too small, plus it had a real 90s import feel to it. Never mind that this IS a 90s import lol. No pics yet as I need some paint correction first! 
 

-Of note is that sometimes on startup it would get massive engine vibration that would clear up after 30 seconds, but throw no code. It always ran fine after startup but finally started  running horribly while I was on the highway  and threw a code when I was 2 hours from home with only my crappy tool kit! 
p0171 and p1133.

A quick limp to the parts store for some MAF cleaner, clean the MAF, still runs like crap, then I realize I cleared my codes but didn't "tell" the computer I fixed anything. So I unplugged the battery for a minute and when I restarted it ran great! No more codes or running bad so hopefully that stays true. Knock on wood. 

7 8 9
Our Preferred Partners
DWikhRjIFzB4RTWRoY5vKmNYbYLL9CRaN6MlzSGRFCcOuUaOD668spMnsORF3txw