bebop
bebop
11/23/19 3:54 p.m.
Hi all,
I have a 92 Dodge Stealth RT/TT
First I'll start off with some background on the issue. About 6 months ago I drove the car and the clutch was working fine. It did jump out of reverse once but I didn't think anything much about it. The car has an aftermarket clutch which is heavy (cant remember the type) but it always worked fine.
Last week I got in and pressed the clutch and it went to the floor. I checked the clutch master cylinder level and it was empty. I refilled it and the pedal came back to normal position. When I pressed it down there was no resistance. I thought it might need to be bled so I tried bleeding it and wasn't getting any fluid out of the bleeder valve. I figured it was a master cylinder so I replaced that (what a nightmare)
Now when I press the pedal it goes about halfway down and hard stops. There is very little if any resistance in the first half of the pedal travel. When I release the bleeder valve the pedal goes to the floor as expected. I bled the system again to make sure there wasn't air in the system and the new master is pushing fluid out the bleeder now. Bleeding the system did not make a difference. I did adjust the pedal some just to make sure that the adjustment wasn't the problem. It didn't seem to make any difference. I visually checked the slave cylinder and dont see any leaking. I tried pressing in the piston with the bleeder valve open and it would not move which may be normal.
Thanks
dean1484
dean1484 MegaDork
11/23/19 6:13 p.m.

The piston bore of the new master may be bigger than the one you took out. Are there multiple masters and slaves available for NA cars versus the TT or was there a change from one year to another?  Early versus late cars?    

AngryCorvair
AngryCorvair MegaDork
11/23/19 9:44 p.m.

If the slave presses a fork that moves the throwout bearing, I’d be looking at the possibility that something got dislodged or is otherwise interfering with that part of the system.  

Our Preferred Partners
GHc26gpJRmFBZBcQifYEtV1QJ9kJ95Jk4ZH1RPMfXe7aCy0uOsb1oeN2Bj68eYyC