Jerry
Jerry UberDork
10/28/19 9:57 a.m.

SWMBO's 2016 (I think) 500X has a driver side power seat, she went to adjust it for the kiddo to drive home one day (yes the kiddo is 15.5yrs old now) & it wouldn't budge.  Any direction, lumbar, nothing.

This weekend I found the fuse box in the cargo area in back (it has 3 boxes) has two fuses for the seat, both looked good.  Managed to unplug and reconnect the massive connector under the seat, still doesn't work.  She reports the heated part still works.

The fact that nothing moves makes me think electrical connection, vs dead motor (think it has more than one).  Tried searching Google and forums over the weekend but the forum didn't work and Google was all "review of seating arrangement" crap.

Any other ideas?  She reminded me it shares many parts with a Jeep, I think Renegade.  Trying to avoid our dealership, the franchise closed & moved to Xenia last year, and so far they do not impress me one bit.

Ranger50
Ranger50 UltimaDork
10/28/19 10:11 a.m.

I suspect the switch panel/module is bad or disconnected. Tough to check without a multiple thousand dollar scanner to read the can bus and individual modules.

John Welsh
John Welsh Mod Squad
10/28/19 10:19 a.m.

I too suspect the switch.  This might be on the side of the seat.  Has there been any coffee or soda spills recently?  Did the switch maybe get kicked by accident?  

Jerry
Jerry UberDork
10/28/19 10:46 a.m.

In reply to John Welsh :

She says no recent spills or anything fishy.  The switch(es) is/are on the side of the seat, maybe I'll look into replacement switch cost?

Our Preferred Partners
J6ktGyFhQnhGovmSXwFWXbm6euMRt9XZxU8E4NjUaNqaFGoZfMpqTCwMnpo4vbyr