1 2 3
KyAllroad (Jeremy)
KyAllroad (Jeremy) PowerDork
2/8/19 6:55 p.m.

So as some of you may know I’m doing the drive leg of my fly-n-drive.  PimpM3 hooked me up with the unicorn X-type (big engine/stick shift) and the car is very much as advertised.  Driving back north it went nearly 200 trouble free miles before I stopped for a leg stretch in South Carolina.   And then the troubles started.

Display cluster reads “cruise not available”.  CEL has popped up.  Car WILL NOT rev past 3,000 rpm.  I stop and get the codes pulled (a whole other barrel of fun, these fine folks don’t want to work on no furrin cars).  It says that both front and rear banks are running lean.  Liberal straying with carb cleaner reveals no obvious vacuum leaks but some shade tree deduction leads me to believe that it’s this.


The car is drive by wire and it feels more “bad TPS” than anything else.  Except that it isn’t actually throttle position, it’s RPM.  It’s fine (or nearly so) at anything under 2,800 rpm.  But foot to the floor it will not exceed 3,000.

So i’ve thrown in the towel for tonight.  Got a cheap hotel room and gonna go grab some dinner, will try again tomorrow.  Anyone have any smart ideas or sage advice can reach me on my cell. 8 five 9 six nine 9 eight 3 four 3.


Cooter SuperDork
2/8/19 7:04 p.m.

Where are you at this point of the trip?

John Welsh
John Welsh Mod Squad
2/8/19 7:16 p.m.

How about Mass Air flow sensor? If it is not reading air correctly then it's not sending fuel correctly.  When I had this problem my car ran very erratically.  It would not run to the higher rpms.  It never threw a code for MAF but threw some other code. 

Your lean code makes me think it is not sending enough fuel based on a bad air reading

CRC cleaner



untchabl Reader
2/8/19 7:17 p.m.

If you're coming thru central NC, you're welcome to come by my place and use my shop & tools. I've never worked on a Jag but my shop is heated and fairly well outfitted with tools. 

Or if you break down coming thru NC, I've got a truck and trailer to save you $$ on a tow.

KyAllroad (Jeremy)
KyAllroad (Jeremy) PowerDork
2/8/19 7:17 p.m.

In reply to Cooter :

200 down 450 to go.

Dusterbd13-michael MegaDork
2/8/19 7:24 p.m.

Im near untouchable as well. We got you if you need us.

What tools do you have access to?

And what behavior doest it have at 3k? Missfire, rev limiter, etc?

Toyman01 MegaDork
2/8/19 7:41 p.m.

Where in SC are you? I'm headed to Darlington, SC in the AM. I might be driving right by you. I'd be happy to stop off and offer assistance. 

pimpm3 SuperDork
2/8/19 7:56 p.m.


I did some research and apparently the not reving past 3000 rpms is the car going into limp mode.  It seems like there are any number of causes, from vacuum leaks to knock sensors.  I did a google search for "jaguar x type 3.0 wont rev past 3000 rpm"

Some folks have had success unhooking the battery which resets the ecu and takes the car out of the limp mode.

The cruise not available signal is sometimes triggered by a vacuum leak according to google.

I am sorry the car is giving you trouble.  Let me know if I can do anything to help.

John Welsh
John Welsh Mod Squad
2/8/19 8:01 p.m.

Some of my Googling brought up the issues of a vacuum leak coming from the brake booster.  Seems to generally cause fits of hard to diagnose 

KyAllroad (Jeremy)
KyAllroad (Jeremy) PowerDork
2/8/19 8:01 p.m.

In reply to Toyman01 :

I’m in Walterboro.  I’ll be around in the morning trying some more things.

I have a screwdriver.  Annoyingly the “TPS” unit is held to the throttle body with 5 point screws that don’t seem to have a driver anywhere.


a_florida_man Reader
2/8/19 8:03 p.m.

What were the specific code numbers?


John Welsh
John Welsh Mod Squad
2/8/19 8:04 p.m.

If heading Jax to Lexington but in the other thread (sale listing) you mentioned wanting to add in The Tail of the Dragon.  If in SC, my guess is that you chose to avoid Atlanta and are on this route. 

John Welsh
John Welsh Mod Squad
2/8/19 8:08 p.m.

If you're about 200 miles into the trip, you're likely near Walterboro, SC not yet to I-20

Edit: wow, I see you said you're there. 

Nick Comstock
Nick Comstock MegaDork
2/8/19 8:10 p.m.

How much gas do you have in it?

I had a car, not a Jaaag though, throw a lean banks 1&2 code when the gas gauge went out and I ran it dry. But it threw it long before the car even hiccuped that I could tell. It happened while going down the interstate. That car didn't go into a limp mode though. Only threw a CEL. 

KyAllroad (Jeremy)
KyAllroad (Jeremy) PowerDork
2/8/19 8:31 p.m.


In reply to Nick Comstock :

Plenty of gas.  Just at 1/2 tank when it went squirely.


Toyman01 MegaDork
2/8/19 8:36 p.m.

In reply to KyAllroad (Jeremy) :

That's about an hour south of me, opposite of the direction I'm headed. 

I don't have a set schedule for tomorrow so I'd be willing to run down there in the morning if you need me to. I don't have any 5 point screw drivers. I do have a OBDII reader though and an assortment of tools in the trunk. Not to mention a willingness to take a ride. 

There is a pretty decent size hardware store a mile or so off I-95 on hwy 64 in Walterboro. Westbury Ace Hardware. They are probably your best bet for specialty screwdrivers and should be open early.


Antihero Dork
2/8/19 8:36 p.m.

Id probably pull a battery cable off and see if anything changes after reset, kinda my goto to see if its mechanical or computer orientated first

Toyman01 MegaDork
2/8/19 8:37 p.m.

Another thought would be a fuel filter stopping up. 


yupididit UltraDork
2/8/19 8:41 p.m.

Have you tried to drive it with the MAF unplugged? 

KyAllroad (Jeremy)
KyAllroad (Jeremy) PowerDork
2/8/19 8:49 p.m.

In reply to yupididit :

Doesn’t even run that way.

In replay to toyman:  

Thanks man, i’ll See what damage I can do to it in the morning.  It doesn’t feel fuel filter related.  Vigo reaches out to me with some diagnostic ideas to try, hopefully I’ll see something good out of that.


dean1484 MegaDork
2/8/19 8:56 p.m.

fly by wire gets screwed up. Usually the throttle. If it sees either end out of spec it puts it in to limo mode. I have an extra one I got as a spare after having two of them fail. I may still have it. There are severial variants so you need to replace them with one with the same part number.

sergio Reader
2/8/19 9:19 p.m.

Clean the throttle body?

nutherjrfan UltraDork
2/8/19 10:47 p.m.

Only vehicle I've had go into limp mode was when I blew a block fuse. Just grabbed the one from my other example. It also hesitated like a bastard until I finally cleaned a not very dirty looking MAF sensor. Hope it all turns out well. smiley

John Welsh
John Welsh Mod Squad
2/9/19 6:04 a.m.
KyAllroad (Jeremy) said:


In reply to Nick Comstock :

Plenty of gas.  Just at 1/2 tank when it went squirely.


It may read a half tank but let's do the math... 

EPA rating of 25 hyw. Specs say 16 gallon tank.  That means a full tank would have a cruising range of 400 miles at 25 mpg.  Or, cruising range of only 320 miles if getting 20 mpg.

You're 200 miles into the trip, had you actually filled the tank yourself since hitting the road?  If yes, your not likely out of gas. 

KyAllroad (Jeremy)
KyAllroad (Jeremy) PowerDork
2/9/19 7:12 a.m.

In reply to John Welsh :

Topped off the tank at the start of the trip and reset the trip-meter.  1/2 tank seemed accurate.

1 2 3
Our Preferred Partners