GameboyRMH
GameboyRMH MegaDork
8/16/19 5:06 p.m.

Came home today and powered up my gaming PC. Pressed the button, nothing happened. Oh boy, more mysterious problems huh? I used my old-school computer power controller to cycle power to it and try again. It's this thing, but color-matched black with the computer for l33tness:

This time when I press the power button, through the case-side window, I see sparks flying and the orange glow of what looks like berkeleyING FIRE inside the case. Now the power controller really comes in handy and I cut power to the computer real quick, luckily the glow disappears.

The fire was coming from a removable bay in the case holding two 10krpm drives in a RAID0 array and an SSD. I figure it's one of the power-guzzling things with moving parts that shot fire so I unplug the hard drives and try again, so far so good, I'm posting from it now. That bay does have a burnt smell. I also happened to have some powder-type ABC extinguishers nearby, but knowing that they work by destroying the fuel so that the fire can't feed on it, that would've been a hard choice to use. The hard drives hold most of the games and some bulk storage data and are backed up, no big deal there, except now's a bad time for me to have to buy some kind of high-performance replacement storage system.

Pete Gossett
Pete Gossett MegaDork
8/16/19 7:52 p.m.

In reply to GameboyRMH :

So you’re saying this RAID isn’t hot-swappable?

I’ll show myself out...

mad_machine
mad_machine MegaDork
8/16/19 11:28 p.m.

if it were a mac, I would suggest he use a fire wire

Knurled.
Knurled. MegaDork
8/17/19 7:23 a.m.

Damn, I haven't seen one of those in forever.

GameboyRMH
GameboyRMH MegaDork
8/17/19 10:08 a.m.

So this morning I took the bay out and inspected the drives. The only imperfection I could find was this debris bridging some of the SATA power pins on one of the drives (they're laptop-size drives that come mounted in an enormous aluminum heatsink to bring them up to 3.5" size, these pins are part of an adapter that moves the ports to the back of the heatsink):

I tried to fish it out with tweezers for closer inspection but it got away from me. Then I cleaned the drives up (very little dust, the computer has positive-pressure cooling with fully filtered intakes), put them back in the bay and powered them up with an external power supply...no sparks. So next I put the bay back in the computer and powered it up with one finger on the computer power cutoff switch...still no sparks, so I'm updating the backup drive now in case there's any more trouble. And not leaving the computer running unattended for a while.

Our Preferred Partners
FjyFhtrgcUaU2yWL29bOXoKFFoy5FvSLBAcuF3S6qZhBiOf2FYTdj0ZcvOMUJ6DS