Klayfish PowerDork
5/5/18 6:05 p.m.

Help!  I know next to nothing about these video game things.  My boys have an Xbox One.  We just bought a Logitech G920 off Ebay.  When we first plugged it in, it was only partly responsive.  The little Xbox logo button responded and so did one or two others, but "B" didn't, the pedals didn't, etc...  I looked up how to reset the calibration, it was something like holding the Xbox logo button and two others while unplugging and replugging in the USB.  Didn't do anything.  I turned off the Xbox console and powered it back up and did the recalibration.  That made it seem to work.  But then we tried to make the car back up and it wouldn't.  The "B" button responded, so he pressed it and backed out of the game, which made the G920 work again.  It's being weird like that.  What am I missing?  It has to be something in the set up.  Does the regular Xbox controller need to have the batteries taken out because it's getting confused (the game responds to that controller still)?  I don't think anything is "broken", because at times all the different buttons and pedals have worked.  It has to be how we have it set up??

failboat UberDork
5/9/18 9:15 p.m.

On 360 with my fanatec i had to turn off the controler before turning on the wheel. Otherwise the wheel would assign to player 2. 

I could switch back and forth between wheel and controller as long as one was turned off before the other was turned on.

dculberson UltimaDork
5/10/18 7:39 a.m.

Yes I think it has to do with which controller the wheel has been assigned to. So if you’re turning the Xbox on with the regular controller then starting the game with that it will assign player 2 the wheel. Try turning the Xbox on with the wheel and starting the game with the wheel. 

Our Preferred Partners