2 3 4
markwemple
markwemple UberDork
6/15/18 7:24 p.m.

So you've upgraded the carb?

Challenger392
Challenger392 Reader
6/15/18 7:47 p.m.

Sorry, i should have been more specific. Original carb is gone. I bought it with 2 dellorto side drafts already installed. Which is a good thing. I would have liked to have the webber on hand just for originality sake. 

markwemple
markwemple UberDork
6/15/18 9:05 p.m.

It's weird to have the delortos. Anything is better than the Weber. That never worked right. The mikunis from my bike would be your upgrade. Mine is going to FCRs. If the delortos are working, cool. That was the set up in the 70s.

markwemple
markwemple UberDork
6/15/18 9:57 p.m.

It appears they do fit. These are the V2 heads, so bigger valves and longer maintenance intervals. I also have an extra set of mikuni carbs.

markwemple
markwemple UberDork
6/16/18 1:50 p.m.

Responded to your email.

nutherjrfan
nutherjrfan SuperDork
6/17/18 11:12 p.m.

Passed by a pristine fully enclosed fairing Ducati on my way to work today.  Shoulda pulled over as I was an hour early. smiley

Trans_Maro
Trans_Maro PowerDork
6/18/18 12:09 a.m.

Which Dellorto carbs are you running?

I've got 36mil pumpers on my Lemans and 32mm pumpers on my 860 GT and they're fantastic carbs to deal with, nor trouble from them at all.

Challenger392
Challenger392 Reader
6/18/18 5:51 a.m.
nutherjrfan said:

Passed by a pristine fully enclosed fairing Ducati on my way to work today.  Shoulda pulled over as I was an hour early. smiley

Ive seen a nice looking 900ss pass by my house quite a few times. Ill have to figure out who it is once I get mine up and running.

Challenger392
Challenger392 Reader
6/18/18 5:53 a.m.

In reply to Trans_Maro :

I have 36mm, it ran pretty great before I botched it up. It had a tinny bit of a hang off idle, but i think something is just sticking a little. 

markwemple
markwemple UberDork
6/20/18 12:24 p.m.

Let me know on the head studs. I'm about to put them up fs on duc sites.

Challenger392
Challenger392 Reader
6/20/18 12:41 p.m.

In reply to markwemple :

Mine must have been replaced they are not silver, thank you. 

markwemple
markwemple UberDork
6/20/18 1:39 p.m.

OK. Yeah, then likely.

minimac
minimac SuperDork
6/20/18 5:36 p.m.

Challenger392
Challenger392 Reader
6/22/18 3:10 p.m.
minimac said:

laugh

Challenger392
Challenger392 Reader
8/5/18 3:49 p.m.

Sorry for the long wait, I know you were holding your breath wink.   I finally got the Bike back together!!!! once I got the head reworked ( new valve and guide)  I just had to re-assemble.  I lucked out with the valve lash.  I only had to sand down one adjuster to get it to work out.  I had to weld a socket to a wrench to torque the head bolts, but what else are cheap china wrenches for?  It runs pretty well, but I think I might have a vacuum leak somewhere as the throttle seems to hang a little when you let off.  Has anyone used reinforced silicone "Boost" hose down stream of carb before?  The reason I ask is that I saw some of it advertised as "not safe for gasoline"  The Oem boots (and aftermarket ones) are expensive and "boost" hose is cheap. 

 

Challenger392
Challenger392 Reader
8/18/18 9:37 a.m.

I rode the bike for 60 miles yesterday and she ran like a charm. No throttle hanging, idles well at 950-1050 rpm, pulls strong, runs nice and smooth (a lot smoother than my brothers 2011 Monster 796). The power seems to drop off at higher RPM but that's probably just the nature of the beast. The only problem now is that the battery light started coming on at anything below 1500RPM. It used to flash a little if it idled down to low (800RPM), now it slowly starts to glow around 1500-1600 RPM's and is on steady below that. hmmm more troubleshooting

Challenger392
Challenger392 Reader
8/18/18 9:38 a.m.

As far as the throttle hanging goes, I did change out 1 carb boot that had a tear in it. That really didn't make much of a change. There were two vacuum lines coming off of the intake manifolds that Tee together and went somewhere up under the seat, not really sure what those were for... I capped them off and that really didn't do much either. I finally broke down and richened the idle mixture screws out 1/4 turn. Now it idles quite nicely and has much less tendency to hang. I probably changed the air fuel characteristics when I added intake track length over its previous config.

 

Challenger392
Challenger392 Reader
8/18/18 9:39 a.m.
Challenger392
Challenger392 Reader
8/18/18 9:42 a.m.

And here it is next to my brothers 2011 796 Monster.

Challenger392
Challenger392 Reader
8/19/18 7:13 a.m.

I figured out where the mystery vacuum hose went. Turns out this bike was converted to marelli digiplex ignition (from the Ducati 900ss/ Paso 906). I suppose I should hook that hose back up and see how it runs. It must be for vacuum advance or something. 

pres589
pres589 PowerDork
8/19/18 9:09 a.m.

Just saw this thread come back up. Good deal on getting the bike back out on the road. 

2 3 4
Our Preferred Partners
3nPmuuT8EwmVgafpMUUuonLitsThwp6YBQIiMD2SusEWTl3r5ZjqCnZsFQbHwhkb